Portal outage

Incident Report for Seal Security

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 16:13 UTC

Identified

Our portal is currently experiencing downtime.
We are actively working to resolve the issue and restore access as soon as possible.
Posted Mar 17, 2025 - 15:57 UTC
This incident affected: Portal.